注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

和申的个人主页

专注于java开发,1985wanggang

 
 
 

日志

 
 

Xmind打不开 A java Runtime Environment(JRE) or Java Development Kit(JDK) must be avaliable in order to run Xmind. No Java virtual machine was found after searching the following locations;  

2013-03-21 10:43:14|  分类: 系统、操作小技巧 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
打开Xmind遇到下面的异常
 A java Runtime Environment(JRE) or Java Development Kit(JDK) must be avaliable in order to run Xmind. No Java virtual machine was found after searching the following locations;C:\Program Files (x86)\Java\jre6\bin\javaw.exe
Xmind打不开 A java Runtime Environment(JRE) or Java Development Kit(JDK) must be avaliable in order to run Xmind. No Java virtual machine was found after searching the following locations; - 和申 - 和申的个人主页
 检查环境变量%JAVA_HOME%对的,%PATH% 中 %JAVA_HOME%\bin都配置了。

奇怪的是eclipse可以打开,xmind也是用eclipse的rcp,那看看配置文件吧
XMind.ini

-vm
C:\Program Files (x86)\Java\jre6\bin\javaw.exe
-product
org.xmind.cathy.product
-configuration
@user.home/Application Data/XMind/configuration-cathy_win32
-data
@user.home/Application Data/XMind/workspace-cathy
-os
win32
-ws
win32
-arch
x86
-startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.200.v20120522-1813
--launcher.defaultAction
openFile
-showsplash
org.xmind.cathy
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Dorg.xmind.product.distribution.id=cathy_win32

-vm
C:\Program Files (x86)\Java\jre6\bin\javaw.exe
这行有问题,我配置的路径是D:/Program Files/Java/jdk1.6.0_32/bin/javaw.exe
看看eclipse的配置正确,可以启动。
eclipse.ini

-startup
plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.100.v20110502
-product
org.eclipse.epp.package.jee.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vm
D:/Program Files/Java/jdk1.6.0_32/bin/javaw.exe
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms256m
-Xmx512m

-vm
D:/Program Files/Java/jdk1.6.0_32/bin/javaw.exe
所以,将XMind.ini的配置修改为 
-vm
D:/Program Files/Java/jdk1.6.0_32/bin/javaw.exe
即可。

放松一下看看:笑话
  评论这张
 
阅读(3558)| 评论(3)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2016