注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

和申的个人主页

专注于java开发,1985wanggang

 
 
 

日志

 
 

The server does not support version 3.0 of the J2EE Web module specification  

2011-12-25 01:00:09|  分类: 项目开发 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

1.错误:

在eclipse中使用run->run on server的时候,选择tomcat6会报错误:The server does not support version 3.0 of the J2EE Web module specification

2.原因:

Tomcat 6.0最多支持Servlet 2.5,而现在要import的项目是3.0版本的。

3.解决方法:

在项目根目录下有一个.settings的文件夹,该文件夹下有一个org.eclipse.wst.common.project.facet.core.xml文件,内容如下:

  1. <?xml version="1.0" encoding="UTF-8"?>  
  2. <faceted-project>  
  3.   <fixed facet="java"/>  
  4.   <fixed facet="jst.web"/>  
  5.   <fixed facet="wst.jsdt.web"/>  
  6.   <installed facet="java" version="1.6"/>  
  7.   <installed facet="jst.web" version="3.0"/>  
  8.   <installed facet="wst.jsdt.web" version="1.0"/>  
  9. </faceted-project>  
  1. <installed facet="jst.web" version="3.0"/>  
改为
  1. <installed facet="jst.web" version="2.5"/>  
即可

http://blog.csdn.net/xw13106209/article/details/7055614
  评论这张
 
阅读(1211)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2016